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Introduction

The ProTuner for DM805-AI is a software tool designed to configure and tune the Leadshine digital drive DM805-AI. The user can tune

the current loop and adjust the anti-resonance parameters in this software.

Workspace

After installing the software and open it, the software is displayed as follows.

Menus and Toolbar

Menu is at the top of the workspace. You can click menu bar to view the pull-down menu.

Menu Pull Down Function

File ->

Open Open a file

Save As Save as a file

Exit Exit ProTuner

Menu

Tuning

and

Property
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Menu Pull Down Function

View ->
Error Log Check the error log

Drive Information DM805-AI specification

Drive->

Connect to Drive Connect to drive

Current Loop Tuning Set current loop parameters Kp and Ki and test.

Property Set drive properties like I/O logic, motor parameters.

Offset Check analog and potentiometer offset

Save to Drive Save all data to drive

Restore Factory Setting Restore factory setting

Help-> About Software Information

Using the Software

Opening a file

If you want to reload the configuration data from a file in the PC, click on the File->Open. The parameters in the software’s workspace

will be updated

Save as a file

Save the data in current workspace to a file and rename it.
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Connecting to Drive Window

Connect to Drive window appears when you open the software. Choose correct serial port and leave the baud rate as default 38400. The

software will try to connect to the drive after you click on the Open button.

!
Notice

Before clicking on the Open button, please make sure:

1) The RS232 cable .has been connected between the drive and the PC’s serial port.

2) The drive has been powered on and the green LED is turned on.

The stepper motor is unnecessary connecting to the drive if you just want to set the parameters but not tuning.

!
Caution

Do not connect or disconnect serial cable when the drive is powered on. The drive’s communication circuit may be

damaged.

Current loop tuning Window

It is used to configure current loop parameters according to different motor. In the tuning window, user can set proportional gain, integral

gain and test value.
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!
Notice

After finishing the input of the number, don’t forget to hit the “Enter” key in the keyboard to confirm new value.

Item Description Range

Proportional Gain

Increase this parameter to make current rise fast. Proportional Gain

determines the response of the driver to current setting command. Low

Proportional Gain provides a stable system (doesn’t oscillate), has low

stiffness, and large current error, causing poor performances in

tracking current setting command in each step. Too large Proportional

Gain values will cause oscillations and unstable systems.

1 – 65535

Integral Gain

Adjust this parameter to reduce the steady error. Integral Gain helps

the driver to overcome static current errors. A low or zero value for

the Integral Gain may have current errors at rest. Increasing the

Integral Gain can reduce the error. If the Integral Gain is too large, the

systems may “hunt” (oscillate) about the desired position.

1 – 65535

Test Value The current amplitude for the step response. 0.5 – 5 A

Test Button
Click this button to activate the test. A target curve (red) and an actual

curve (green) will be displayed on the screen for user analysis.
-
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Property Window

The user can set the drive’s anti-resonance parameters, output current, microstep, electronic damping and stop mode according the motor

and application.

!
Notice

Microstep setting is only effective in Pulse/Direction mode.
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Item Description Range

The 1st Resonance Area It is usually between 0.6 to 1.2 RPS. -

The 2nd Resonance Area It is usually between 1.2 to 2.4 RPS. -

The 3rd Resonance Area It is usually between 2.4 to 4.8 RPS. -

Amplitude

Amplitude adjustment for anti-resonance tuning. 0 – 3500 for

the 1st, 2nd resonance area and 0- 256 for the 3rd resonance

area. The user can enter a value directly in the text box or move

the slider bar back and forth to get an optimum value.

0 – 3500 or 0-

256

Phase

Phase adjustment for anti-resonance tuning. The user can enter

a value directly in the text box or move the slider bar back and

forth to get an optimum value.

0 – 1608 or 0-

256

Dynamic Current

Drive’s output current setting according to the motor. It should

be less than the motor’s related current * 1.414.

Note: The DIP switch setting must be SW1 = off, SW2 = off,

SW3 = off if you wan to set this parameter in ProTuner.

0.5 – 7.0 A

MicroStep

Drive’s Microstep setting for the motor.

Note1: The DIP switch setting must be SW5 = off, SW6 = off,

SW7 = off, SW8 = off if you wan to set this parameter in

ProTuner.

Note2: The microstep is effective only in Pulse/Direction

mode.

1 – 512

Electronic Damping
Adjust this parameter to improve the drive’s high speed

performance. The optimal value depends on the system.
0 - 6000

Stop Mode

The motor stops immediately when a stop command is applied

to the drive if this parameter is immediate stop. Otherwise the

motor stops with a acceleration set by the Accel/Ramp or

Decel/LoSpeed potentiometers.

-
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Offset

It is used to check the offset of the potentiometers and analog input in factory. The user can ignore it.

Save to Drive

After the drive’s configuration and tuning is done, you need to click Drive->Save To Drive to save the data to drive’s nonvolatile

memory. Otherwise the data will not be lost after power-off.

Restore Factory Setting

This command is used to restore the factory data when the drive is out of control or the user want to do that.

Configuring the drive

If it is the first time setup, you can follow the steps below to configure the drive.

1) Set motor related parameters such as dynamic current, microstep and stop mode according to the motor and application.

2) Tune the current loop parameters.

3) Tune the anti-resonance parameters if necessary.

4) Adjust the electronic damping when the high speed performance is not good.

!
Notice

The motor must be connected to the drive before trying to configure the drive.

!
Caution

After finishing the input of the number, don’t forget to hit the “Enter” key in the keyboard to confirm new value
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Set motor related parameters

Click Drive->Property to open the Property window. You can set the motor’s dynamic current, microstep and stop mode.

The motor’s dynamic current is related to the related current. Usually, the motor manufacturer states the RMS (root mean square) current

in datasheet. Please relate to the hardware installation manual for how to set the dynamic current.

!
Notice

The DIP switch setting must be SW1 = off, SW2 = off, SW3 = off if you wan to set this parameter in ProTuner.

The microstep is so important is only effective in Pulse and Direction command mode. High resolution microstep makes the motor move

more smoothly. Low microstep resolution reduces the high frequency requirement to the controller.

!
Notice

1. The DIP switch setting must be SW5 = off, SW6 = off, SW7 = off, SW8 = off if you wan to set this parameter in

ProTuner.

2. The microstep is effective only in Pulse/Direction mode.

The motor stops in the acceleration set by the potentiometer. If the application needs fast stop, please click Immediate Stop.
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Tune the current loop

The DM805-AI’s current loop need to be tuned before normal operation in order to get optimize responses with different motors.

Otherwise the motor will be easily stall or howls when power-up. Below is the tuning process for a NEMA 23 motor with 24VDC

supply voltage.

Step 1: Set Test Value 1 and start the tuning with small Proportional Gain and “zero” Integral Gain. Here we set Proportional Gain

500.

Step 2: Click the Test button and the plot window will show two curves. The red one is target current and the green one is actual

current. There is large gap between them in the scope. It indicates that a large Proportional Gain needs to be introduced.

Step 3: Increase Proportional Gain to 1000 and click Start. The gap between target value and actual value is smaller but a higher

Proportional Gain is still needed.

Initial Value

Proportional Gain = 500

Integral Gain =1

Start Test:

Proportional Gain = 500

Integral Gain = 1
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Step 3: Give Proportional Gain 2000, 3000, 4000 and click Test button, respectively. The green curve is getting more and more close

to the red curve. Over-shoot is obvious when we increase Proportional Gain to 4000. It indicates that you need to stop increasing Kp

and back off. Our purpose is to make the green curve (the actual current) a little higher than the red curve (the target). So we decrease

Kp to 3700 until the actual value is exactly over the target value.

↑ Proportional Gain:

Proportional Gain = 1000

Integral Gain = 0

↑ Proportional Gain:

Proportional Gain =2000

Integral Gain = 1

↑ Proportional Gain:

Proportional Gain =3000

Integral Gain = 1
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Step 4: Now the Proportional Gain is relatively good enough. But there is still gap between the green curve and the red curve when

we use the mouse to zoom in the green curve. So we need to introduce Integral Gain to reduce the “gap” or steady error at the constant

part. It follows the same procedure as Proportional Gain. High Integral Gain causes big vibration, system lag and makes the

performance worse. The following figures show how to tune the integral gain.

↑ Proportional Gain:

Proportional Gain =4000

Integral Gain = 1
Over-Shoot

↓ Proportional Gain:

Proportional Gain =3700

Integral Gain = 1

Drag a triangle to zoom in
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Step 5: The current loop tuning is basically finished. You can continue to adjust Kp and Ki for better performance. Now the updated

Kp and Ki is just stored in the driver’s RAM. They will be lost when we power off the driver. Don’t forget to click Drive->Save To

Drive to store the changed value to the drive’s EEPROM.

Zero Integral Gain:

Proportional Gain =3700

Integral Gain = 1

↑Integral Gain:

Proportional Gain =3700

Integral Gain = 200

↑Integral Gain:

Proportional Gain =3700

Integral Gain = 400
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Anti-resonance Tuning

Step motors are highly resonant, which results in vibration and ringing. The ringing utilizes a large fraction of the motor's available

torque – thereby wasting performance. Furthermore, at mid-range velocities, the resonance can become so severe that the motor looses

synchronization and stalls. The DM442 drive provides robust anti-resonance control to stop the vibrations and maintain equilibrium.

This feature requires that the drive be configured with respect to the total inertia in the system. If set improperly, the effectiveness of the

feature may be diminished.

!
Notice

1. For most of the application, it is not needed to tune DM805-AI’s anti-resonance parameters. We only recommend the

advance user to use this function as it is a boring process.

2. In most of the case, only the tuning of the 1st and 2nd anti-resonance area has obvious effect.

Step 1: Connect the drive as follows and configure it in Low/High Speed mode by set SW7 = OFF and SW8 = ON. As the Speed input

is connected to Signal GND, the motor speed is determined by the LoSpeed potentiometer and it can be adjusted from 0RPS to 5RPS.

Further Adjustment:

Proportional Gain =3500

Integral Gain = 300

Save all the changes to the drive’s

non-violated nonvolatile memory.
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Accel/Ramp
Decel/LoSpeed

HiSpeed

COM+
Run/Stop/Pulse

Direction/+Limit
Speed/(-)Limit
Enable/Disable

Signal GND

+5V Output
0~5V Input

Signal GND
Signal GND

Power GND
+20-80VDC

Motor A+
Motor A-
Motor B+
Motor B-

DM805-AI

Motor

20-80VDC

Disable
Speed

Direction
Run/Stop

Ramp
LoSpeed
HiSpeed

Step 2: Start to move the motor by activating the Run/Stop input. Find a resonance speed by slightly adjusting the LoSpeed parameter

CW and CCW.

Step 3: Keep the motor running at the resonance speed and verify the motor smoothness. You may find a better smoothing value by

slightly moving the slider bars of Amplitude and Phase back and forth. If the motor speed is 0.6-1.2RPS, you should tune the Amplitude

and Phase at the 1st resonance area. The 2nd resonance area is 1.2-2.4 RPS and the 3rd resonance area is 2.4 4.8 RPS.

!
Notice

1. You can calculate the motor speed roughly as follows:

Turns

terPotentiomeLoSpeedofTurns
(RPS)Speed(RPS)

25
01.05 

2. It is very important to make the Amplitude and Phase adjustments at the resonance speed.

For example, we find a resonance speed at 0.98 RPS. We begin to move the Amp1 slider forth and the motor vibration and noise became

lower and lower. Finally we find the move is the smoothest when Amplitude is 3300. The motor vibration and noise increase if

Amplitude exceeds 3300. Then we follow the same procedure to search the best point for Phase. See Figure 26. Anti-resonance tuning is

done.

Step 4: Click Drive->Save To Drive to save all the parameters to DM805-AI.

Adjusting the Electronic Damping

The factory setting for the electronic damping is 1000. If the motor is easily stalled and generates odd noise at middle speed, you can try

other values such as 500, 1500, 2000, 2500.



DM805-AI Software Operation Manual

15SW-DM805AI-R20110826

Contact Us

China Headquarters

Address: 3/F, Block 2, Nanyou Tianan Industrial Park, Nanshan District Shenzhen, China

Web: http://www.leadshine.com

Sales Hot Line:

Tel: 86-755-2641-7674 (for Asia, Australia, Africa areas)

86-755-2640-9254 (for Europe areas)

86-755-2641-7617 (for Europe areas)

Fax: 86-755-2640-2718

Email: sales@leadshine.com.

Technical Support:

Tel: 86-755-2641-8447, 86-755-2641-8774, 86-755-2641-0546

Fax: 86-755-2640-2718

Email: tech@leadshine.com(for All)

Leadshine U.S.A

Address: 25 Mauchly, Suite 318 Irvine, California 92618

Tel: 1-949-608-7270

Fax: 1-949-608-7298

Web: http://www.leadshineUSA.com

Email: sales@leadshineUSA.com and support@leadshineUSA.com.
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