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EM Series Stepper Drive Software Operational Manual

Introduction

The ProTuner is a software tool designed to configure and tune the Leadshine EM series digital stepper drives include EM402, EM503,
EM705 and EM806. The user can configure the drive’s output current, micro step, electronic damping, command type, tune the current

loop and adjust the anti-resonance parameters in this software.

Workspace

Leadshine ProTuner for EN503 - [Test_20111026. 1=sd]

File Drive Tools Help Menu
Toolbar
Properties
Enable/Disable Features
~ Output Settings

1. DIF swithes 1. 2. and 3 must he setto "OM" to allow output current change

2. DIP swithes 5. 6. 7. and 8 musthe setto "OMN" to allow "Micro Step”, or resolution change

Output Current (4) |1.91 Mirco Step |4 .

Properties
ldle Current (%5) |50 Idle Start Time (ms)  [2000 Electrical Damping |1ggg

Window

~Input Settings
r Command Type

& Step / Direction

~Active Edge
© DwWITOW & Rizing

 Falling

rDirection Change
& Low

mAlarm Signal
 High  Active Law

& Active High

Cormunication Complete

Apply |

Leadshine Technology Co.,Ltd.

Data: 2011-10-26

Menus and Toolbar
Menus and toolbars are at the top of the workspace. You can click menu bar to view pull-down menu. The toolbar below offers the most

frequency used commands.
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Leadshine Home Page Click to visit Leadshine Home Page

Menu Pull Down Toolbar Function
Open @ Open a file
S [ | L S fil
ave - ave a file
File ->
Save As - Save as a file
Close - Close the current file
Exit - Exit from the software
Connect To Drive - Connect to drive
Current Loop A Configure current loop parameters Kp and Ki.
) Set drive properties like output current, Micro Step,
Properties p 1 - . s g
command type, electronic damping and active edge.
Drive > et | yp 1 ping 1ve edg
o Configure the built-in pulse generator which is used
Build-in Generator IE; ) )
for anti-resonance tuning and self-test.
Download to Drive - Download data to drive
Reset Drive - Reset drive to factory setting
Error Log Check the drive error log.
Tools->
PIN Management - Change the drive’s PIN
Hardware Manual on Web - Click to view EM drives hardware installation manual.
Software Manual on Web - Click to view EM drives software operational manual.
Help->

About Leadshine ProTuner Software Information
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Using the Software

Opening a file

If you want to load the configuration data from a file in the PC, click on the File->Open. The parameters in the software’s workspace

will be updated. The file name will appear in the tile bar.

E_{]I.eadshine ProTuner for EN503 - [Test_ _20111026. 1=d]
File Driwe Tools Help

File Name

Save a file

Click Drive->Save to save the data of current workspace to the open file. If there is no file opened, the Save Dialog appears and you can

type in the file name then save it.

Save as a file

Click Drive->Save As to save the data in current workspace to a file and rename it.

Close

Click Drive->Close to close the current file.
Connecting Drive

@Cnm’lect to Drive E|

Selectthe right serial portto connect the drive to your
computer

Serial Port:

Cloze |

Connect to Drive window appears every time you open ProTuner. You can also open it by clicking Drive->Connect any time. Select
the serial port and click on the Connect button. The software will try to connect to the drive and read the settings. It may take several

minutes. Please wait.
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Before connecting the drive, please make sure:
1) The RS232 cable .has been connected between the drive and PC serial port.
2) Power has been applied to the drive and the green LED is turned on.

The motor is no need to connect to the drive if you just want to change the parameters but not tuning.

A Do not connect or disconnect serial cable when drive is powered on. The drive’s communication circuit may be damaged.

Current Loop Tuning Window
Current Loop E|
J Red Curve:
Target Current of Step Test
Cal /I

\l\

Green Curve:

Actual Current of Step Test

kp | 2202 Ki 734 Tast Current (4) &

Self-TestAnd

L A U Auto-Configuration

Click Drive->Current Loop to open the current loop tuning window. You can adjust the Kp (proportional gain) and Ki (integral gain) in

this window. These parameters should be tuned before normal operation.

Item Description Range

Increase Kp to make current rise fast. Proportional Gain determines the

response of the drive to current setting command. Low Proportional

Kp Gain provides a stable system (doesn’t oscillate), has low stiffness, and
(Proportional Gain) large current error, causing poor performances in tracking current 170999

setting command in each step. Too large Proportional Gain values will

cause oscillations and unstable systems.
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Adjust Ki to reduce the steady error. Integral Gain helps the drive to
overcome static current errors. A low or zero value for the Integral Gain
Ki
may have current errors at rest. Increasing the Integral Gain can reduce 1—65535
(Integral Gain) L
the error. If the Integral Gain is too large, the systems may “hunt”

(oscillate) about the desired position.

EM402: 0.5-2.2A
The current amplitude for the step response. Let this value not exceed EMS503: 0.5 -4.2A

Test Current ) )
the maximum output current of the drive. EM705:: 0.5 -7.0A

EMB&806:: 0.5 - 8.2A

Enter Kp and Ki and click this button to activate the test. A target curve

Manual Tuning (red) and an actual curve (green) will be displayed on the screen for user -
analysis.
Self-test and Click this button to activate self-test and auto-configuration. The Kp
Auto-configuration and Ki will be tuned automatically.

Properties - Input/Output Settings

Properties

Input/Output Settings! Enahle/Disahle Featuras

Output Settings
1, DIF swithes 1, 2, and 3 must be setto "OMN" to allow output current change
2. DIF swithes 5. B, 7. and 8 must be setto "ON" to allow "Micro Step". or resolution change

Qutput Current (&) hirco Step

Idle Current (%) |50 Idle Start Time (ms)  [2000 Electrical Damping 1000
Input Settings
Command Type Active Edge
™ Step/Direction " CW/CCW ' Rising " Falling

Direction Change
* Low " High & e

e |

Click Drive->Properties to open the Properties window. In the Input/Output Settings Tab, the user can set Output Current, Micro

Step, Idle Current, Electronic Damping, Pulse Active Edge and Command Type.

1. DIP switch must be in Default mode (SW1, 2 for EM402 and SW1, 2, 3 for the others) to allow current change.
A 2. DIP switch must be in Default mode (SW4, 5 for EM402, SW5, 6, 7, 8 for EM503 and EM705, SWS5, 6, 7 for
EMS806) to allow Micro Step change.
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Item Description Range

Drive’s output current for the motor. It should be less than 1.4

times of the motor’s RMS current/phase. EM402: 0.07-2.2A

Note: The DIP switch setting must be in default mode as EMS503: 0.21-4.2A
Output Current

follows to be configured by software. EM705: 0.35-7.0A

EM402: SWI1 =o0n, SW2=on EMB806: 0.35-8.2A

EMS503, EM705, EM806: SW1 = on, SW2 = on, SW3 = on

Drive’s Micro Step setting for the motor.
Note: The DIP switch setting must be in Default mode as
follows to be configured by software.
Micro Step 1-512
EM402: SW4=on, SW5=on
EMS503, EM705: SWS5 =on, SW6 = on, SW7 = on, SW8=on

EMB806: SW5 =on, SW6 = on, SW7 = on

Idle current at motor stop. The drive goes into idle state when
Idle Current there is no pulse applied to it and the DIP SW3 (EM402), SW4 10%-100%
(The others) is set to OFF.

The time when there is no pulse applied to the drive. The drive
Idle Start Time . o 1-5S
goes into idle state after this time.

Adjust this parameter to improve the drive’s high speed
Electronic Damping . 1-6000
performance. The optimal value depends on the system.

Command Type or pulse mode of control signal. Select
PUL/DIR or CW/CCW according to command type of motion

e PUL/DIR
Command Type controller. PUL/DIR means pulse and direction mode; R
CW/CCW means double pulses mode. (Note: The EM402 and
EMS806 only support step & direction command.)
X Pulse active edge. The motor shaft moves one micro step every Rising
Active Edge ] -
active edge. /Following
Change the motor direction. It is only active in PUL/DIR . .
L. L (High)Positive
Direction Change command mode. Please note that the actual direction is also .
] ] /(Low)Negative
related to the motor coil connection.
Set active impedance for the alarm (fault) signal. Active High
means high output impedance for drive error and Active Low .
] . Active Low
Alarm Signal means low output impedance for driver error. (Note: The . .
. /Active High
Alarm Signal of the EM503 and EM705 can not be configured,
fixed at Active Low.)
Apply Apply Button. Click this button to apply all the changes. -
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Properties - Enable/Disable Features

Properties
InputfCutput Settings ‘Enable/Disable Features
W Phase Error Detection W Sensoress Stall Detection
W EMA to Resetthe Drive W EMNA Active High

I Pulse Filter Enahle

Apply

This window offers options of enabling phase error detection, motor stall detection and pulse filter. You can also set the active signal of

the enable signal and use it for drive reset to clear the error.

Item Description

Check it to enable phase error detection which is activated when motor
Phase Error Detection connection is wrong or one of the motor lead is disconnected. The alarm/fault

output will be active if it is enabled.

Check it to enable motor stall detection without sensor. The alarm/fault output
Sensorless Stall Detection
will be active if it is enabled.

Check it to let the enable signal to reset the drive which is in error state. The

ENA to Reset the Drive
drive will restart and all the error will be clear.
ENA Active High Check it to set the active high for ENABLE signal.
Pulse Filter Enable Check it to enable the pulse filter which smooth the command input.
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Built-in Controller for Self-test

w Build-in Generator

Tuning Resonance Area 1

Ampitude 1 |

|
J
Fhase 1 |0 1

Tuning Resonance Area 2
Ampitude 2 |0 |
Phase 2 |n 1

Tuning Resonance Area 3

Ampitude 3 128
Phase 3 128

Build-in Controller for Seli-test
lse the slider below to change vourtest speed. twill be displayed on "Speed" text box automatically.

L —

o

bl

Speed (ps) g Acceleration (r/s72) 200 Interval Time {ms) |50

kaotar bowing Directian
Distance (1) 10 FRepest 5 ¥ Positive and Negative W Positive

L

You can adjust the anti-resonance parameters in this window. The built-in controller can be used for anti-resonance tuning and self test.

Item Description Range

The 1st Resonance Area It is usually between 0.6 to 1.2 RPS. -

Amplitude adjustment for the 1* anti-resonance area. The user can enter a
Amplitude 1 value directly in the text box or move the slider bar back and forth to get 0-3500

an optimum value.

Phase adjustment for the 1% anti-resonance area. The user can enter a
Phase 1 value directly in the text box or move the slider bar back and forth to get 0-1608

an optimum value.
The 2nd Resonance Area It is usually between 1.2 to 2.4 RPS. -

Amplitude adjustment for the 2" anti-resonance area. The user can enter a
Amplitude 2 value directly in the text box or move the slider bar back and forth to get 0-3500

an optimum value.
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Phase 2

The 3rd Resonance Area

Amplitude 3

Phase 3

Speed

Acceleration

Interval Time

Repeat

Motor Moving Direction

Start

Phase adjustment for the 2" anti-resonance area. The user can enter a
value directly in the text box or move the slider bar back and forth to get

an optimum value.
It is usually between 2.4 to 4.8 RPS.

Amplitude adjustment for the 3™ anti-resonance area. The user can enter a
value directly in the text box or move the slider bar back and forth to get

an optimum value.

Phase adjustment for the 3™ anti-resonance area. The user can enter a
value directly in the text box or move the slider bar back and forth to get

an optimum value.

Display the current speed when you move the slider.
Acceleration of Built-in Controller.

Interval between the positive and negative move.
Repeat times.

If it is positive, the motor moves only in positive direction. If it is
positive and negative, the motor moves in both positive and negative

direction.

Click to start the motion.

0-1608

0-256

0-256

0-20 RPS

1-65535

1-65535

1-65535
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Error Log Window

Click Tool->Error Log to open the error log window. This window shows both the present status of each error event and their history.

Exrror Log rgl

Over Current

OwerWolkage

Phase Emar

Stall

- 900 ®
- 900®
~ @00 ®
- 900®®
- 900
« 900
- §0e®
o L 1L L
* @0 ®®
- @0 e ®

Ermar Counter

. Clsar All Enars |

Item Description
Over Current The motor coil current exceeds the output limit of the drive.
Over Voltage The input voltage exceeds the input limit of the drive.
Phase Error Wrong motor coil connection or one of the motor lead is disconnected.
Stall The motor has been stalled.
Clear All Errors Clear the error log.

PIN Management Window

FIN Nanagement E|
= Inlock Protection r5_<|
!ﬁ"?)\ Set or Change PIN Number —
Jt!r"' f 3\ Drive configurations are protected. Enterthe
FIN number must be a 4 digital number ‘glr preset FIN number to Connect

PIM = PN [
Carfirm PIN W

(0]:8 ‘ Cancel |

Continue

Cancel ‘

Every EM drive has a 4-digit PIN (Personal Identification Number). The default PIN is 0000. If you don’t want the drive’s configuration
from read by others, set or change the PIN number in this window. Next time the software communicates with the drive, it requires the
operator to enter the PIN number. If you forget the PIN, the only way to communicate with the drive again is resetting the drive by

clicking Drive->Rreset Drive. The PIN will be 0000 again and all the data is reset to factory setting.

10
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Configuring the Drive

If it is the first time setup, you can follow the steps below to configure the drive.

1)  Set Input/Output parameters like output current, Micro Step and command type according to the motor and application.
2) Tune the current loop parameters with the connected motor.

3) Tune the anti-resonance parameters if necessary.

4)  Adjust the electronic damping when the high speed performance is not good.

A The motor must be connected to the drive before trying to configure the drive.

Set Input/OQutput Parameters

Click Drive->Properties to open the Property window. You can set the Output Current, Micro Step and Command Type.

Properties

Input/Output Settings! Enahle/Disahle Featuras

Output Settings
1, DIF swithes 1, 2, and 3 must be setto "OMN" to allow output current change
2. DIF swithes 5. B, 7. and 8 must be setto "ON" to allow "Micro Step". or resolution change

Qutput Current (&) hirco Step

Idle Current (%) |50 Idle Start Time (ms)  [2000 Electrical Damping 1000
Input Settings
Command Type Active Edge
™ Step/Direction " CW/CCW ' Rising " Falling

Direction Change
* Low " High & e

e |

In most of the application, it is required to set only the output current, Micro Step and Command. Usually, the motor manufacturer states

the RMS (root mean square) current in datasheet. Please refer to the hardware installation manual for how to set the output current.

1. DIP switch must be in Default mode (SW1, 2, for EM402 and SW1, 2, 3 for the others) to allow current change.

2. DIP switch must be in Default mode (SW4, 5 for EM402, SWS5, 6, 7, 8 for EM503 and EM705, SWS5, 6, 7 for
A EMB806) to allow Micro Step change.

3. The EM402 and EM806 only support step & direction command.

High resolution Micro Step makes the motor move more smoothly. Low Micro Step resolution reduces the high frequency requirement

to the controller. See the EM drives hardware installation manual for more information for how to select the Micro Step.

11
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Current Loop Tuning

The current loop parameter needs to be tuned before normal for optimize responses with different motors. Otherwise motor will be

casily stalled or howls at power-up. Below is the tuning process of EM705 for a NEMA 23 motor with 24VDC supply voltage.

g Before trying to tune the current loop parameters, select “custom” in the motor selection table for the rotation switch.

Please note that change of motor requires re-power of drive.

Step 1: Set Test Current 0.5 and start the tuning with small Kp and “zero” Ki. Here we set Kp=500 and Ki=1.

Current Loop E'

Initial Value
Kp =500
Ki=1

Kp 500 Ki 1 Test Currant (A) 05

Menuel Tuning -

Step 2: Click the Test button and the plot window will show two curves. The red curve is target current and the green curve is actual

current. There is large gap between them in the scope. It indicates that a large Kp needs to be introduced.

Current Loop E|

Start Test:
Kp =500
Ki=1

Kp 500 Ki 1 Test Current (A) 5

12
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Step 3: Increase Kp to 1000 and click Start. The gap between target value and actual value is smaller but a higher Kp is still needed.

Current Loop E'
t Proportional Gain:
Kp =1000
Ki=1
Kp | 1000 Kio| 1 Test Current (A A

Step 3: Give Kp 2000, 3000, 4000 and click Manual Tuning, respectively. The green curve is getting more and more close to the red
curve. Over-shoot is obvious when we increase Kp to 4000. It indicates that you need to stop increasing Kp and back off. Our purpose is
to make the green curve (the actual current) a little higher than the red curve (the target). So we decrease Kp to 3700 until the actual

value is exactly over the target value.

Current Loop E'

t  Proportional Gain:
Kp =2000
Ki=1

Kp | 2000 ki |1 Test Current (4 A

Menuel Tuning -

13
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Current Loop E'
t Proportional Gain:
Kp =3000
Ki=1
K 3000 Ki 1 Test Current (A) 5
Current Loop E'
§ t Proportional Gain:
~— @@
Kp =4000
Over-Shoot
Ki=1

K 4000 Ki 1 Test Current (A) 5

Manel Tuning -

Current Loop E'
V Proportional Gain:
Kp =3700
Ki=1
kp | 3700 Kio| 1 Test Current (4) 5

14
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Step 4: Now the Kp is relatively good enough. But there is still gap between the green curve and the red curve when we use the mouse

to zoom in the green curve. So we need to introduce Ki to reduce the “gap” or steady error at the constant part. It follows the same

procedure as Kp. High Ki causes big vibration, system lag and makes the performance worse. The following figures show how to tune

the integral gain.

Current Loop

7 Ly
/

Drag a triangle to zoom in

Kp | 3700

Kio| 1 Test Current (4) A

5

Current Loop

Kp | 3700

Kio| 1 Test Current (4) A

X

Zero Integral Gain:
Kp =3700
Ki=1

15
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Current Loop rg'
Kp | 3700 Ki 200 Test Current (A) 5
S -
Current Loop rg'
Kp | 3700 Ki 400 Test Current (A) 5

kanual Tuning

e

t Integral Gain:
Kp =3700
Ki=200

t Integral Gain:
Kp =3700
Ki=400

Step 5: The current loop tuning is basically finished. You can continue to adjust Kp and Ki for better performance. Now the updated

Kp and Ki is just stored in the driver’s RAM. They will be lost when we power off the driver. Don’t forget to click Drive->Download
To Drive to store the changed value to the drive’s EEPROM.

16
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Current Loop &|

Further Adjustment:
Kp =3500
Ki=300

Kp | 3700 Ki 300 Test Current (A) 5

Menuel Tuning -

Conmect to Drive

Current Loop

. Save all the changes to the drive’s
Froperties

Euild-in Generator non-violated nonvolatile ~memory.

You need to close the current tuning

window firstly.

Reset Drive

17
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Anti-resonance Tuning

Stepper motors are highly resonant, which results in vibration and ringing. The ringing utilizes a large fraction of the motor's available
torque — thereby wasting performance. Furthermore, at mid-range velocities, the resonance can become so severe that the motor looses
synchronization and stalls. The EM drive provides robust anti-resonance control to stop the vibrations and maintain equilibrium. This
feature requires that the drive be configured with respect to the total inertia in the system. If set improperly, the effectiveness of the

feature may be diminished.

1. For most of the application, it is not needed to tune EM drive anti-resonance parameters. We only recommend the
A advance user to use this function as it is a boring process.

2. In most of the case, only the tuning of the 1% and 2™ anti-resonance area has obvious effect.

Step 1: Start the motion test by clicking Start/Stop button. Find a resonance speed by slightly moving the slider bar of internal pulse

generator back and forth. You can also use the arrow keys to adjust the speed precisely.

Step 2: Run the motor at the resonance speed and verify the motor smoothness. You may find a better smoothing value by slightly
moving the slider bars of Amplitude and Phase back and forth.

It is very important to make the Amplitude and Phase adjustments at the proper test speeds with an unloaded motor. Running at an
incorrect test speed will not excite the motor at its peak resonance, making it more difficult to find proper adjustment values. Optimum

Amplitude and Phase values may be a little different between running the tests with an unloaded motor and a load motor.

Step 3: Keep the motor running at the resonance speed and verify the motor smoothness. You may find a better smoothing value by
slightly moving the slider bars of Amplitude and Phase back and forth. If the motor speed is 0.6-1.2RPS, you should tune the Amplitude

and Phase at the 1% resonance area. The 2™ resonance area is 1.2-2.4 RPS and the 3" resonance area is 2.4 4.8 RPS.

For example, we find a resonance speed at 0.98 rps. We begin to move the Amp1 slider forth and the motor vibration and noise became
lower and lower. Finally we find the move is the smoothest when Amplitude 1 is 3300. The motor vibration and noise increase if
Amplitude 1 exceeds 3300. Then we follow the same procedure to search the best point for Phase 1. See Figure 26. Anti-resonance

tuning is done.

Step 4: Click Drive->Download To Drive to save all the parameters to EM drive’s nonvolatile memory.

Adjusting Electronic Damping

The factory setting for the electronic damping is 1000. If the motor is easily stalled and generates odd noise at middle speed, you can try

other values such as 500, 1500, 2000, 2500.

18
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Contact Us

China Headquarters
Address: Floor 11, Block A3, iPark 1001 Xueyuan Blvd., Nanshan District, Shenzhen, Guangdong, China

Web: http://www.leadshine.com

Sales Hot Line:

Tel: 86-755-2641-7674 (for Asia, Australia, Africa areas)
86-755-2640-9254 (for Europe areas)
86-755-2641-7617 (for Europe areas)

Fax: 86-755-2640-2718

Email: sales@leadshine.com.

Technical Support:
Tel: 86-755-2641-8447, 86-755-2641-8774, 86-755-2641-0546
Fax: 86-755-2640-2718

Email: tech@leadshine.com(for All)

Leadshine U.S.A

Address: 25 Mauchly, Suite 318 Irvine, California 92618
Tel: 1-949-608-7270

Fax: 1-949-608-7298

Web: http://www.leadshineUSA.com

Email: sales@leadshineUSA.com and support@leadshineUSA.com.

19
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